23 de mai de 2010

Corrigindo a resolução do Plymouth de forma simples (Chrome9 HC + Ubuntu 10.04)

Esta solução foi testada com as placas de vídeo onboard VIA Chrome9 HC (VN896) e Intel 82945G/GZ. Os problemas aqui relatados foram observados em um Notebook Itautec W7635 "equipado" com uma Chrome9 HC

Detalhe da tela de carregamento do Ubuntu 10.04
Nem tudo é perfeito! Muitos usuários estão tendo problemas com a tela de carregamento do Lucid Lynx. No meu caso, a imagem do Plymouth fica enorme e fora de centro. Cheguei a testar ESTA SOLUÇÃO. Mas, além de aumentar o tempo de boot, causou travamentos aleatórios e outras esquisitices ao carregar o GDM.

No entanto, existe uma solução muito simples para o problema, que não interfere no tempo do boot e que até o momento não travou o sistema na tela de login.

O único ponto negativo é que, aparentemente, o logotipo do Ubuntu demora um pouco para aparecer (eu disse aparentemente...), deixando a tela totalmente escura por alguns segundos. Mas quando o logo aparece, aparece direitinho. :)

Então, se quer testar esta solução, faça isto:
É recomendável que você desfaça qualquer configuração que tenha feito anteriormente na tentativa de resolver o problema com o Plymouth (exceto as que coincidem com a dica abaixo)

1 - No Terminal, digite:
sudo gedit /etc/default/grub

2 -Localize a linha "#GRUB_GFXMODE=640x480" e, abaixo dela, adicione a seguinte:
GRUB_GFXPAYLOAD_LINUX=1280x800

Obs: a resolução pode ser modificada conforme a sua preferência/necessidade. Instale o pacote hwinfo e use o comando sudo hwinfo --framebuffer para verificar as resoluções suportadas pela sua placa de vídeo.

No meu caso, ficou assim:
#GRUB_GFXMODE=640x480
GRUB_GFXPAYLOAD_LINUX=1280x800

Opcionalmente, você pode remover o comentário da linha "#GRUB_GFXMODE=640x480" e modificar a resolução para 1280x800 (resolução do Grub). Neste caso, ficaria assim:
GRUB_GFXMODE=1280x800
GRUB_GFXPAYLOAD_LINUX=1280x800

Salve e feche o arquivo.

Atualização (chega de tela preta!)

Continuando...

3 - Depois execute este comando:
echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash

Antes de executar o comando acima, a imagem do Plymouth levava mais ou menos 26 segundos para aparecer. Agora aparece em menos de 10 segundos (o tempo total de boot, no meu Notebook, é de cerca de 31 segundos até o GDM).

4 - Atualize as configurações do Grub e gere uma nova imagem initramfs:
sudo update-grub2 && sudo update-initramfs -u

5 - Reinicie o sistema.

Simples assim!

Leia também:

3 comentários

Anônimo disse...

Tenho o mesmo Notebook que o seu (ItauTec W7635), mas o som não funciona no Skype.

Como você conseguiu resolver o problema do som?

Desde já, agradeço

Rodrigo Miguel disse...

Tenho o mesmo Notebook que o seu (ItauTec W7635), mas o som não funciona no Skype.
Como você conseguiu resolver o problema do som?


Eu não uso Skype. Não tenho problemas com o som. A não ser quando abro as propriedades, no ícone do volume. Se faço isto, o som "morre". Então, evito abrir as propriedades... :)

Recomendo que você peça ajuda no Fórum Ubuntu PT: http://ubuntuforum-br.org/

:)

Jacarezinho disse...

Eu tenho um notebook igual ao de vocês (Itautec W7635), e o meu som também não funcionava no Skype, mas consegui resolver!

Basta você remover o Pulse e instalar o ALSA.

Na seqüência, vá ao Seletor de Sistema Multimídia e selecione sempre o ALSA. Nas preferências do Ubuntu, o ícone do Seletor estará oculto e você deverá ativá-lo.

Não instale o Skype 2.1.0.81

Você deverá instalar o Skype 2.1.0.47

Dentro das configurações de áudio do Skype, deixe o microfone para hw 0,0. O resto, deixe como default.

Pronto!

Você poderá usar o seu Skype com tranqüilidade.