1 de mai de 2011

Como iniciar o GNOME 3 sem o GNOME Shell (modo de reserva/fallback mode)

Para dar uma resposta mais completa ao @_Heyron do Twitter, que perguntou se tinha como deixar o GNOME 3 no estilo do 2, não tipo um Unity da vida [sic]...

1 - Acesse o menu de status (menu de estado do usuário, canto superior direito) e clique em "Configurações do sistema";

2 - Clique no ícone "Informação do sistema".

3 - Na opção "Gráficos", habilite o "Modo de reserva forçado" (Forced Fallback Mode).

Ativando o Modo de reserva forçado

4 - Reinicie a sessão.

O resultado:

GNOME 3 sem o GNOME Shell (modo de reserva/fallback mode)

PS: minha dificuldade agora é, depois de experimentar o GNOME Shell, voltar para o velho estilo do GNOME 2... ;)

Update

Uma outra forma de forçar o sistema a iniciar no modo fallback é adicionar o parâmetro nomodeset na tela de boot (GRUB). Isso também ajuda a identificar e resolver problemas caso o GNOME Shell apresente alguma falha (erro) e não seja possível iniciar a interface gráfica e fique retornando ao GDM (tela de login).

6 comentários

Anônimo disse...

habilitei o modo reserva, mas gostaria de habilitar também o menu "sistema", além de aplicativos e locais. tem jeito?

Rodrigo Miguel disse...

Re: @Anônimo

No GNOME 3, o menu Sistema foi substituído pela opção "Configuração do sistema" do menu do usuário (no canto superior direito).

Anônimo disse...

Parece q essa opção sumiu na versão final do 11.10
Não acho ela aqui

Rodrigo Miguel disse...

Re: @Anônimo acima

Para utilizar o modo fallback no Ubuntu 11.10, é preciso instalar o pacote gnome-session-fallback. Após a instalação, selecione, na tela de login, a opção "GNOME Clássico" ou "GNOME Clássico" (sem efeitos)".

Coletivo Jovem - PI disse...
Este comentário foi removido pelo autor.
Bianca Oliveira disse...

Oi Rodrigo,

Meu problema já é o inverso, quero sair do modo de reserva no Debian Testing, Wheezy, tentei teu tutorial ao contrário, mas não me aparece opções para alterações (on/off). Sabes o que posso fazer?

Desde já agradeço =)

PS: No fedora 15, funcionava tudo legal..