7 de jul de 2010

Erro ao iniciar o Emesene no Ubuntu 10.04 - Resolvido

A atual versão do Emesene (1.6.1-0ubuntu1, que está disponível nos repositórios do Lucid Lynx) exibe, quando executado, a seguinte mensagem de erro:
Exception
You are using emesene 1.6.1 "mate" so you're free to complain here:
http://forum.emesene.org/index.php/board,19.0.html
Check already existing tickets for duplicates first, please.
Traceback (most recent call last):

blá blá blá...

IndexError: list index out of range
Sobre o motivo do erro

Para resolver o problema, recomendamos a atualização do Emesene para a sua versão mais recente, disponível no seu respectivo repositório PPA.

O processo é bastante simples. Basta executar a seguinte sequencia de comandos:
sudo apt-get purge emesene -y

sudo add-apt-repository ppa:bjfs/ppa

sudo apt-get update

sudo apt-get install emesene

O quê os comandos acima fazem: o primeiro remove o aplicativo, o segundo adiciona um novo repositório, o terceiro atualiza a lista de pacotes e o último instala a versão atualizada.

Pronto. O mensageiro deve estar atualizado e funcionando.

Update

Se o problema retornar, após alguma atualização do PPA, sugiro a instalação do pacote disponível para o Debian testing (link para download).

Erro GPG (erro de chave pública) - Corrigindo...

Para obter a chave pública do repositório adicionado anteriormente, execute o seguinte comando:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E2314809

Ou use o método manual (para os casos em que o comando acima não funcione):

1 - Abra o gedit, oopie o texto abaixo e salve com um nome qualquer:
Public Key Server -- Get ``0x0cc1223ee2314809 ''

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: SKS 1.0.10

mI0ESf4k7QEEAK1rJAFg10Tqp9SmyK5dhbXhkoI+WZRkGf6GJFlzWGx/f9oIqgjBUpsezb8m
lXz8+1GAOlROOyL250kaE9QfgtRv3cHD/9ripF4OUvKHOoSE0R0BZ5uBKQv5m11BMrWe3O07
jHUSSwAKxWTxnpLy/pnsw+SyZPbVRgOz+wI0VVRvABEBAAG0IExhdW5jaHBhZCBQUEEgZm9y
IEIuSi4gU3RvYmllY2tpiLYEEwECACAFAkn+JO0CGwMGCwkIBwMCBBUCCAMEFgIDAQIeAQIX
gAAKCRAMwSI+4jFICR/WBACO5kqmQxlrJGEs13HQSNWdmkZcoFjLd1s2uWckaKBVRN3lMHti
AjeTCN2sraMV5aj0+pB7dEr/+gHqzGHH6yLTPJaUCkCLwaVZtBZi70jVl3RGISpxRlwCMCsw
M1C00+Gu4Vgi59qsry7F3ZNMKXa4IdqnIumcXcC9hf/KbRjRvQ==
=XBkJ
-----END PGP PUBLIC KEY BLOCK-----

2 - Abra o Gerenciador de pacotes Synaptic. Acesse o menu Configuração > Repositórios, aba "Autenticação". Clique no botão "Importar Arquivo Chave..." e a seguir localize e importe o arquivo salvo anteriormente (duplo clique sobre o mesmo). Feche a janela.

3 - Clique no botão "Recarregar" do Synaptic para atualizar a lista de pacotes.

Vai dizer que achou difícil? ;)

Leia também:

0 comentários